We are continuing to monitor for any further issues.
Posted Oct 21, 2025 - 01:17 UTC
Monitoring
The AWS services have started recovering. The incident duration was from 06:50 - 09:30 UTC. Unfortunately, during that period many workflow automations have failed due to never being ingested in the first place - many of our partner vendors experienced the same outage. We advise manual checking & replaying all workflow automations during that period. We continue to monitor the health of our infrastructure and taking various mitigation actions.
Posted Oct 20, 2025 - 10:11 UTC
Identified
There is a major global outage with AWS affecting US-east-1 which is part of our critical infrastructure. There is currently partial outage on Keragon's webhook ingestion service & the Keragon dashboard. Our engineers our working to mitigate the situation.